现在的位置:首页>wordpress>正文

无需升级,您的WordPress数据库已经是最新的了的解决

2015年05月16日 ⁄ 共 1018字 暂无评论

每次wordpress发出新的版本,部落都会在第一时间进行更新,当然,也建议大家进行更新,这样的话,安全性和稳定性会更好,但有时候,我们会因为更新而出现"无需升级,您的WordPress数据库已经是最新的了"的提示,这个时候,不要慌张,冷静一下,很容易就能解决的.

今天进网站后台,突然发现提示:“无需升级,您的WordPress数据库已经是最新的了”,然后就点不进去后台了,咋办呢?求助百度呗。后来知道了原来是由于后台自动更新到wordpress4.2.2,但仍有缓存导致的,如下图所示:

无需升级,您的WordPress数据库已经是最新的了

阿里云OCS缓存解决方法

由于我使用的是缓存载体是阿里云的OCS,所以实际上还有另外一种方法,那就是进入阿里云的管理控制台,直接删除当前的缓存,也可以解决此问题,入图所示:

阿里云OCS缓存

当然,如果您用的是其它的VPS,也可以按上述方法找到对应的地方试试.

删除object-cache.php文件

下面的这个方法来源自逍遥乐IT博客,内容如下:

今天wordpress4.0正式发布,我想进入后台进行升级!但是输入wp-admin地址进入后台界面却跳转到另外一个界面:提示

无需升级,您的WordPress数据库已经是最新的了!

让我很头疼的是所有后台页面都是这个!

考虑到我本身还没有升级到4.0,所以文件基本上没有更改!会不会是缓存的问题!首先我卸载了Hyper Cache插件,结果依然不行!最后我想到了Memcached缓存!

所以我进入了wp-content文件夹删除object-cache.php文件,重新进入后台。果然,问题解决了,成功进入了后台!

现在我把我遇到的问题写出来,下次大家遇到同样的问题,能够做一个参考!产生此类问题往往是由于wordpress程序缓存造成的!可以回想自己的wordpress程序是否安装了某些缓存插件,而后进入FTP,直接将缓存插件名称更改一下,或将所有已经产生的Cache缓存文件夹删除(例如widget-cache,object-cache,wp-super-cache,wp-widget-cache等).

注意:一般的缓存文件都在插件文件夹里,也有的插件缓存文件会在wp-content目录下或者其他你没有注意到的位置,更改完成就可以正常登录wordpress后台了!

小结

文章内容来源自街头诗人,由免费部落整理发布.

当然,正常情况下,遇到这种事情,我们需要先检查一下自己网站中的缓存插件.另外,更新前最好还是关掉所有的缓存插件.

给我留言